Topp-node for Oppgaveplanlegging

Oppgaveplanlegging

Du kan bruke Oppgaveplanlegging til å planlegge at kommandoer, programmer eller skript skal kjøres på bestemte tider:

  • Før du bruker Oppgaveplanlegging, kan du se Sjekkliste.
  • Hvis du vil ha hjelp med bestemte oppgaver, kan du se Hvordan.
  • Hvis du vil ha generell bakgrunnsinformasjon, kan du se Begreper.
  • Hvis du vil ha anvisninger for å løse problemer, kan du se Feilsøking.


Sjekkliste for Oppgaveplanlegging

Sjekkliste

Tabellen nedenfor viser de handlingene du utfører oftest med Oppgaveplanlegging. Hvis du vil ha en fullstendig liste over anvisninger for Oppgaveplanlegging, kan du se Hvordan.

Steg | Referanse
Før du kan planlegge at en oppgave skal utføres, må du legge til oppgaven. | Planlegge en ny oppgave
Når planlagte oppgaver er opprettet, kan du endre programmet, tidsplanen eller detaljene for en bestemt oppgave. | Endre en planlagt oppgave
Planlagte oppgaver som ikke lenger er nødvendige, kan du fjerne helt. | Fjerne en planlagt oppgave
Hvis en planlagt oppgave starter mens du bruker datamaskinen, kan du stoppe oppgaven og starte den på nytt senere. | Stoppe en planlagt oppgave som er i gang
Du kan stoppe alle planlagte oppgaver midlertidig og sette dem i gang igjen senere. | Stoppe alle planlagte oppgaver midlertidig


Hvordan...

  • Planlegge oppgaver
  • Adminstrere Oppgavebehandling


Planlegge oppgaver

  • Starte Oppgaveplanlegging
  • Planlegge en ny oppgave
  • Endre en planlagt oppgave
  • Fjerne en oppgave
  • Stoppe en planlagt oppgave som er i gang
  • Kjøre en oppgave med en gang


Starte Oppgaveplanlegging

Slik starter du Oppgaveplanlegging

  • Du kan starte Oppgaveplanlegging ved å dobbeltklikkeMin datamaskin og deretter dobbeltklikke Planlagte oppgaver.
  • Dobbeltklikk Planlagte oppgaver og dobbeltklikk så Legg til planlagt oppgave for å åpne Veiviser for planlagte oppgaver, som leder deg gjennom planleggingen av en oppgave.


Planlegge en ny oppgave

Slik planlegger du en ny oppgave

  1. Start Oppgaveplanlegging.
  2. Dobbeltklikk Legg til planlagt oppgave.
  3. Følg anvisningene i veiviseren for registrering av nye oppgaver.

Merknader

  • Hvis du vil konfigurere avanserte innstillinger for oppgaven, merker du av for alternativet Åpne avanserte egenskaper for denne oppgaven når jeg velger Fullfør i det siste skjermbildet i veiviseren.
  • Hvis du vil at en ny oppgave skal utføres flere ganger hver gang den blir utført, merker du av for alternativet Åpne avanserte egenskaper for denne oppgaven når jeg velger Fullfør i det siste skjermbildet i veiviseren, velger kategorienTidsplan og klikker Avansert.
  • Hvis programmet oppgaven skal utføre krever parametre, merker du av for alternativet Åpne avanserte egenskaper for denne oppgaven når jeg velger Fullfør i det siste skjermbildet i veiviseren. Deretter klikker du kategorien Oppgave og skriver parametrene i Kjør, etter banen til oppgaven.
  • Kontroller at systemdato og klokkeslett for datamaskinen er nøyaktig. Oppgaveplanlegging er avhengig av denne informasjonen for å vite når de planlagte oppgavene skal utføres. Hvis du vil kontrollere eller endre dato og klokkeslett, dobbeltklikker du klokkeslettet i oppgavelinjen.


Endre en planlagt oppgave

Slik endrer du en planlagt oppgave

  1. Start Oppgaveplanlegging.
  2. Høyreklikk oppgaven du vil endre og klikk Egenskaper.
  3. Gjør ett eller flere av følgende:
    • Hvis du vil endre programmet som kjøres, skriver du banen til det nye programmet i Kjør.
    • Hvis du vi endre tidsplanen for oppgaven, velger du kategorien Tidsplan.
    • Hvis du vil tilpasse innstillingene for oppgaven, velger du kategorien Innstillinger.

Merknader

  • Hvis du endrer brukerkonto eller programmet som kjøres, må du angi passordet for brukerkontoen.
  • Hvis programmet for oppgaven krever kommandolinjealternativer, skriver du dem i Kjør, etter banen til oppgaven.
  • Hvis banen til programmet for oppgaven inneholder mellomrom, må du sette anførselstegn ("") rundt hele banen til oppgaven.
  • Pass på at systemdato og klokkeslett for datamaskinen er nøyaktig, siden Oppgaveplanlegging er avhengig av denne informasjonen for å vite når de planlagte oppgavene skal utføres. Hvis du vil kontrollere eller endre dato og klokkeslett, dobbeltklikker du på klokkeslettindikatoren i oppgavelinjen.


Fjerne en planlagt oppgave

Slik fjerner du en planlagt oppgave
  1. Start Oppgaveplanlegging.
  2. Høyreklikk oppgaven du vil fjerne og klikk Slett.

Merknader

  • Når en planlagt oppgave blir fjernet, blir bare tidsplanen fjernet fra listen over tidsplaner. Programfilen blir ikke fjernet fra harddisken.
  • Du kan også fjerne en planlagt oppgave ved å trykke DELETE-tasten.


Stoppe en planlagt oppgave som er i gang

Slik stopper du en planlagt oppgave som er i gang

  1. Start Oppgaveplanlegging.
  2. Høyreklikk oppgaven du vil stoppe og klikk så Avlutt oppgave.

Merknader

  • Hvis en planlagt oppgave starter et annet program, vil denne kommandoen bare stoppe den opprinnelige planlagte oppgaven, ikke den andre oppgaven.
  • Hvis du vil starte en stoppet oppgave på nytt, høyreklikker du oppgaven og klikker så Kjør.


Kjøre en oppgave med en gang

Slik kjører du en oppgave med en gang

  1. Start Oppgaveplanlegging.
  2. Høyreklikk oppgaven du vil starte og klikk Kjør.

Merknader

  • Du kan stoppe oppgaven ved å klikke Avslutt oppgave på Fil-menyen.
  • Hvis en oppgave skulle ha blitt utført men ikke ble det, kan du velge Vis logg i Avansert-menyen for å se på oppgaveloggen.


Administrere Oppgaveplanlegging

  • Vise en logg over tidligere planlagte oppgaver
  • Vise planlagte oppgaver på eksterne datamaskiner
  • Stoppe alle planlagte oppgaver midlertidig
  • Stoppe Oppgaveplanlegging midlertidig
  • Angi konto for AT-tjeneste


Vise en logg over tidligere planlagte oppgaver

Slik viser du en logg over tidligere planlagte oppgaver

  1. Start Oppgaveplanlegging.
  2. I menyen Avansert velger du Vis logg.


Vise planlagte oppgaver på eksterne datamaskiner

Slik viser du planlagte oppgaver på eksterne datamaskiner

  1. På skrivebordet dobbeltklikker du Andre maskiner .
  2. Dobbeltklikk datamaskinen du vil vise planlagte oppgaver på.
  3. Klikk Planlagte oppgaver.

Merknader

  • Du kan vise oppgaver på en ekstern datamaskin som kjører Windows bare hvis du er administrator på den aktuelle datamaskinen.
  • Du kan redigere oppgaver på en ekstern datamaskin som kjører Windows bare hvis denne datamaskinen har programvare for eksternt register installert og har delt ressursen x$, der x er harddisken der mappen Planlagte oppgaver ligger. Datamaskinen som kjører Windows må også ha din brukerkonto spesifikt med på listen over de som har ekstern registertilgang. Du kan angi hvilke brukere som har ekstern registertilgang til en datamaskin som kjører Windows ved å klikke Passord i kontrollpanelet.


Stoppe alle planlagte oppgaver midlertidig

Slik stopper du alle planlagte oppgaver midlertidig

  1. Start Oppgaveplanlegging.

  2. I menyen Avansert velger du Stopp Oppgaveplanlegging midlertidig.

Merknader

  • Denne kommandoen er nyttig hvis du kjører et annet program (for eksempel et spill) eller installerer programvare og du ikke vil at planlagte oppgaver skal kjøre samtidig.
  • Oppgaver som skulle vært kjørt mens Oppgaveplanlegging er midlertidig stanset blir ikke kjørt før neste gang de er planlagt utført.
  • Hvis du vil gjenoppta tidsplaner for alle oppgaver velger du Avansert-menyen og klikker Fortsett Oppgaveplanlegging .


Stoppe Oppgaveplanlegging midlertidig

Slik stopper du Oppgaveplanlegging midlertidig

  1. Start Oppgaveplanlegging.
  2. I menyen Avansert velger du Stopp Oppgaveplanlegging .

Merknad

  • Når du slår av Oppgaveplanlegging blir planlagte oppgaver ikke utført, og Oppgaveplanlegging starter ikke automatisk neste gang du starter Windows.


Velge konto for AT-tjeneste

Slik velger du konto for AT-tjeneste
  1. Start Oppgaveplanlegging.
  2. I menyen Avansert velger du Konto for AT-tjeneste.
  3. Klikk Denne kontoen, og skriv så brukerkontoen som skal kjøre oppgaver som er planlagt ved hjelp av kommandoen at.
  4. I Passord og Bekreft passord skriver du riktig passord for kontoen.

Merknader

  • AT-tjenesten er bare tilgjengelig på Windows NT.
  • Alternativt kan du klikke Systemkonto. Hvis du gjør det, utfører Oppgaveplanlegging oppgavene fra at-kommandoen ved hjelp av kommandoen LocalSystem, som krever administratorrettigheter.

  • Brukerkontoen du angir må ha de riktige tillatelsene til å kjøre de oppgavene du planlegger ved hjelp av at-kommandoen. Hvis du for eksempel planlegger programmer som bare kan kjøres av administratorer, må brukerkontoen du angir være en adminstratorkonto.


Oppgavebehandlingsbegreper

Begreper

Denne delen inneholder generell bakgrunnsinformasjon om Oppgavebehandling:

  • Innføring i Oppgavebehandling
  • Bruke Oppgavebehandling
  • Oppgavebehandling og kommandoen At
  • Oppgavebehandling og sikkerhet
  • Feilsøking


Innføring i Oppgaveplanlegging

Ved hjelp av Oppgaveplanlegging kan du planlegge at oppgaver (for eksempel Diskdefragmentering) skal bli utført på de tidspunktene som passer best for deg. Oppgaveplanlegging starter hver gang du starter Windows, og kjører i bakgrunnen.

Med Oppgaveplanlegging kan du:

  • Planlegge at en oppgave skal bli utført daglig, ukentlig, månedlig eller på bestemte tider (for eksempel når datamaskinen starter).
  • Endre tidsplanen for en oppgave.
  • Stoppe en planlagt oppgave.
  • Tilpasse hvordan en oppgave blir utført på planlagt klokkeslett.


Bruke Oppgaveplanlegging

Windows-operativsystemet installerer automatisk Oppgaveplanlegging. Hvis du vil bruke planleggingstjenesten, dobbeltklikker du mappen Planlagte oppgaver i Min datamaskin.

Du kan legge til oppgaver ved å dobbeltklikke Legg til planlagt oppgave slik at Veiviser for planlagte oppgaver starter. Du kan legge til oppgaver ved å dra skript, programmer eller dokumenter fra Windows Utforsker eller skrivebordet til vinduet Planlagte oppgaver.

Du kan også bruke Oppgaveplanlegging til å endre, slette, stanse midlertidig eller permanent oppgavene du har planlagt, vise en logg over tidligere planlagte oppgaver eller vise oppgaver som er planlagt på en ekstern datamaskin.

Hvis du vil ha detaljert informasjon om å bruke Oppgaveplanlegging, kan du se Fremgangsmåte.

Bruke Oppgaveplanlegging best mulig

I Windows-operativsystemet kan du bruke Oppgaveplanlegging til å planlegge at programmer skal utføres. For å få best mulig nytte av Oppgaveplanlegging, må du kontrollere at systemdato og klokkeslett er riktig innstilt før du legger til en oppgave.


Bruke Oppgaveplanlegging og at-kommandoen

Oppgaveplanlegging og At-kommandoen

I tillegg til Oppgaveplanlegging kan du også bruke at-kommandoen til å kjøre oppgaver automatisk.

Oppgaveplanlegging er ikke det samme som at-kommandoen, men de to arbeider sammen. Når du planlegger en oppgave ved hjelp av at-kommandoen, kommer den frem i listen over oppgaver i Oppgaveplanleggingsvinduet.

Du kan bruke Oppgaveplanlegging til å endre egenskapene til en oppgave som ble planlagt ved hjelp av at-kommandoen. Hvis du gjør dette, må du fortsette med å bruke Oppgavebehandling for å få tilgang til oppgaven. Du kan ikke lenger få tilgang ved hjelp av at-kommandoen.

Hvis du vil angi hvilken brukerkonto som skal utføre oppgaver som er planlagt med at-kommandoen, velger du Planlagte oppgaver fra Min datamaskin og velger Konto for AT-tjeneste i Avansert-menyen.

Merknad

  • AT-tjenesten er bare tilgjengelig på Windows NT.


Oppgaveplanlegging og sikkerhet

I oppgaveplanlegging kan du konfigurere sikkerhet ved å tildele brukernavn og passord til en bestemt oppgave. Når brukernavn og passord er fastsatt, kan oppgaven ikke slettes eller oppheves av en annen bruker.

Merknader

  • Denne sikkerhetsfunksjonen er bare tilgjengelig på Windows NT.
  • Du må angi et brukernavn i Veiviser for planlagte oppgaver før du kan fortsette med å planlegge en oppgave. Passord er ikke påkrevet.
  • Du kan endre eller angi nytt passord ved å merke av for alternativet Åpne avanserte egenskaper for denne oppgaven når jeg velger Fullfør i det siste skjermbildet i veiviseren.


Feilsøking på Oppgaveplanlegging

Hvis en oppgave du har planlagt ikke blir utført når du hadde ventet det, kan du høyreklikke oppgaven og klikke Egenskaper. I kategorien Oppgave kontrollerer du at alternativet Aktivert er valgt. I kategorien Tidsplan kontrollerer du at tidsplanen er riktig innstilt.

Hvis et program i en oppgave ikke blir utført på riktig måte, kan det være at du må legge til kommandolinjealternativer. Hvis du vil vite mer om et bestemt program og hvilke kommandolinjealternativer det har, kan du prøve:

  • Skjermbasert hjelp for programmet, hvis det er tilgjengelig.

  • Skrive dette etter kommandoledeteksten: (der program er navnet til programmet)

    • program /?


Windows NT-komponent ikke installert

Dette programmet kunne ikke starte.

Mulige grunner:

    • Programmet ble fjernet av systemadministrator.
    • Systemadministrator endret kriteriene for filen.
    • Programmet er ikke installert på datamaskinen.
    • Progammet ble slettet ved en feil.
    • Filen er skadet.

Hvis en systemadministrator styrer maskinen, bør du kontakte administratoren for å finne ut hvorfor du ikke kan starte programmet.